Strange render issue with converted blueprint (4.2.1 -> 4.3.1)


I migrated a character blueprint using a modular approach from 4.2.1 to the new 4.3.1. I use the github version, compiled from source and did so with 4.2.1 My current version in the about dialog says 4.3.1-0+UE4

Anyway, my character consists of three skeletal meshes. Body, Pants, Shirt. Put together in a blueprint, set aniumation, worked fine in 4.2. Opened/Converted the project with 4.3 caused a corruption(?):
the cloths render ok when near, but disappear when far away. I have rebuilt the blueprint from scratch in 4.3 and it renders fine, no matter the distance.
I have compared all settings of the meshes, the blueprint, the animation,… I can’t find any obvious difference. The render issue persists in Editor mode and even in a packaged project. I’ve tried rebuilding everything.
See attached screenshots.
What causes the error?


Never mind. In 4.2 blueprint the “Enable Update Rate Optimizations” option for the body mesh was checked.
I unchecked it, renders fine again.
I missed it being different from the new blueprint, and I swear I looked over the properties like 10 times… :frowning:
no idea how it got enabled though.
Anyway, this issue is resolved!