Strange physics-related hitches in 4.11

After testing out the 4.11 preview, I found that my physics-based game was having some very strange hitches and stuttering.

When comparing side-by-side, I can see that while rolling a skeletal mesh that has several linked capsules, it appears to be a frame or so behind every once in awhile, then it will jitter and catch up. This is especially obvious that it’s linked to the physics of the skeletal mesh when I compare it to motion being driven by blueprints on objects with their physics disabled. The other objects motion seems consistent with the framerate and looks very smooth, especially compared to the physics-driven skeletal meshes in the scene.

The only feature that I’m using that’s out of the ordinary is physics sub-stepping. I’ve got it set to 12 max substeps and a max substep delta time of 0.005.

Comparatively, this hitching and jittering is not present in the project in 4.10. I can provide videos or sample project files if anyone needs them, just let me know what might work best to diagnose the problem. Thanks!

Hey, I’m still running into this in 4.11. Any idea what might be causing it? Thanks.

Hi BrianMay,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • Is this limited to a specific asset?
  • What steps can I take to reproduce this error on my end?

Hi BrianMay,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

Ok yeah, sorry, I’ll get a test scene put together this afternoon and share my results. Thanks!

Did a bit more research and have concluded that it’s isolated to a project that I’ve converted from 4.10. Would you like me to zip it up and send it over?

If I start a new scene and bring the same assets over, the behavior is not present.

If you could provide the project I would be willing to take a look and see what may be occurring.

I saw that you have tried turning on and off Substepping, have you tried turning on Substepping Async or altering the various values within the Framerate settings?

Yes, I tried async, and I tried altering the parameters for the substepping values, and they didn’t seem to change anything about how the motion worked.

btw, I shot you a PM on the forums with a link to the project if you’d like to take a look. Thanks!

oh cool! yeah that seems to eliminate that jitter if I turn the camera lag off, or if i set the speed super high. Unfortunately, I have to set it so high that the lag is basically negated to get it to function correctly. Conversely, if I set the speed to be super super low, then I can still see the jitter present as the actor rolls away.

If you knock over barrels with the speed set super low, you can see the barrels’ motion as pretty smooth and it starkly contrasts with the movement of the player’s head.

I’d love to be able to set camera lag attributes around 10 for rotation and movement lag. Those values seem to nicely smooth out the motion of the player’s pawn as it rolls up and down over its own tentacles. If the speed is set too high, or if we turn it off, then the motion of the camera is very jarring as the player’s head moves up and down quickly while it rolls over surfaces and objects.

Any idea what might have changed for this between 4.10 and 4.11? This is a direct conversion, and so no parameters have changed.

We’ve been digging inside the project and have found that the jittering you are seeing is actually on the camera component inside of your pawn. Specifically, it seems that the Camera Lag and Rotation Lag are the primary culprits. Try turning this off to see if you see the jittering stop. If you need them on, try adjusting the values to a higher value and see if the jittering still occurs, it may simply be too low.

Unfortunately it is difficult to know for certain at present what the difference may be. 4.11 is currently in a preview state and as such some aspects may be unstable or untested. The best option would be to continue active development in 4.10 until the 4.11 release occurs. Once this happens you can check to see if it was simple instability or if there is a specific error occurring in 4.11 that isn’t in 4.10.

Hi Adam, thanks for getting back to me. I just double checked, and this issue is still present in the 4.11 official release. Let me know if you’d like me to make a new bug or if I can update with any new info. Thanks!

If you could, please update the information here so we can keep it all in one location.

Sure no problem. I’ll continue to dig through the 4.11 release to see if I can figure out more of why this is happening, but I’m still shooting in the dark a bit as to why it would change so drastically from 4.10 to 4.11

Hi BrianMay,

Have you had any luck with this? More than likely there was a PhysX code change that has altered the behavior and simply need to be taken into account.

I think I did end up getting to the bottom of this! It looks like the setting to Enable Async Scene was what was causing the disparity between 4.10 and 4.11. In my 4.10 version of the project, I have async scene disabled and it works fine. Nice and smooth. If I switch over to 4.11 with the same settings, it appears jittery and broken. If I check Enable Async Scene in the project’s settings, then it smooths it out nicely.

I’d love to use the synchronous scene, since the whole game is physics-based, and I’d hate to run into some weird order-related bugs later down the line. Any idea why the synchronous scene might be jittering like this in 4.11 vs 4.10?

More than likely there was a code change to address bugs that may have been found in previous engine versions and this alteration caused the change you are seeing.

I take it all back. 4.11 still introduces weird physics-related hitches even with async scene turned on in a different map. No idea what the difference is.

Is it the same hitching or is it different? Do you have any steps I can take to reproduce this on my end?