Download

Strange issue: defaults resetting on BPs derived from other BPs

Just throwing this out here to see if anyone else has encountered this, and maybe knows of a way to fix it.

In my current project, I have a base class (in BP) for throwable objects, i.e. anything that the player can, well, throw. The base class is of course never instanced, but used to handle all the general stuff that applies to any specific throwable, which are individual BP classes using the base as parent.

This was working as expected until yesterday, when the default values for variables defined in the base class suddenly started going back to ‘0.0’ or ‘None’ or whatever’s the appropriate basic default for each data type, even though they had specific non-zero values set in the base class.

The strangest thing is that everything seems to work fine while fiddling with this in a single UEeditor session, but if I save everything, quit the editor, and then load it back up, then all the derived classes will have their defaults zeroed out again.

I’ve tried reparenting and then going back to the intended base class again to see if that would refresh things a bit (and it does, but resets again when the editor is closed/reopened). I’ve tried making all the defaults private in the base class, and adding setters/getters where needed. All sorts of strange things, but nothing has helped.

To work around this, today I ended up setting all values explicitly in the construction script for each child BP, which does indeed work reliably, but it’s hardly an ideal solution going forward.

So… has anyone seen this? Did you find a solution?

Oh, and this applies to 4.6.0.

Hi Xenome,

Can you post this to the answerhub in the bug reports section so we can better assist you? This can be found at http://answers.unrealengine.com. Thank you!

Hi Adam - sure thing, reposted here: Defaults resetting on BPs derived from other BPs - UE4 AnswerHub

I’m now experiencing this on 4.7.4 on a BP only project, and its super annoying and is breaking functionality.