Download

Strange BP Error when saving a level

Hi i just created a new level for my “game” and wanted to make an logical minigame in my game so i created a new BP with bunch of stuff inside.
All the static meshes are inside of the bp and all works fine with the Minigame logic.

But when i want to save the Level enginge shows this message and don save the level.
http://i1380.photobucket.com/albums/ah198/Krzysztof_Kantoch/message%20error_zps5mnwwwq1.jpg

I also realized that this only happens when this bp is spawned on the level if i delete it wworks fine.

This is how it looks
http://i1380.photobucket.com/albums/ah198/Krzysztof_Kantoch/bug%20shot%202_zpsqpmpogvn.jpg

Its basically few static meshes with 5 colsion boxes wich lets me change the material of the balls.

We had this problem on our project.

I took the time to delete each node one by one (in the problematic blueprint) until I can save.

At some point, I deleted the node that was the cause of the problem and it all worked fine (I simply rebuilt my blueprint node by node after that).

I found it. Its not exactly what you said but i just tested few thing when i been rebuiliding the BP.

This mesage start to appear when you make copies of UStaticMesh Components.

Creating new meshes gives no problem. But when i tried to copy and paste the mesh the error started again.
At least in my case when i make copies (Ctrl+C) inside of my blueprint then i paste it with (Ctrl+V) the message start to appear when im trying to save.
So its probaably that when you make copies the reference to blueprint of the mesh is being broke

Creating completly new meshes gives me no problem at all

Yep, I can confirm this!

Ran into this issue, too. I just copied some static meshes in the BP and got the same error.

I also ran into this issue a lot.
But for me it happens on some functions. I abuse them for global defaults, silly things like negate float. Pure functions are awesome way to make blueprints less messy.

What solves this problem for me is to turn off save on compile. then compile manually all blueprints that give errors. It usually goes away after first 2 or 3.

This should be fixed somehow by epic, or given better error report. I migrated my project 3 times because of it (asset by asset), could not get rid of this error.
Then i found out aboe way to easily fix it. Something is quite messy with unreal blueprints, this is too easy to get error.

I made an propper bug report on answer hub on this so they hopefully they fix this in future. Copyng scaled objects were a lot faster but for now i will stick to create each one separately. :frowning:

For newbies wich are reading this thread: https://docs.unrealengine.com/latest/INT/Engine/Components/StaticMesh/index.html
These are Ustatics comonents. U can drag and drop m in the vieport of any blueprint.