Download

Stopping collision from disappearing on matinee?

Hey guys, I’m making a game where you jump from one platform to another.

The platform I’m using is “S_NEC_PILLAR_SM_DECOPILLAR1”. I have a trigger in place, which “on touch” -> matinee.play (the matinee makes the pillar fall down slowly over 5 seconds).

PROBLEM1: The collision on the pillar disappears when the matinee is set up. (I’ve tried multiple models, redefining collision, setting block_all, etc.)

PROBLEM2: Trigger.untouched -> matinee.reverse (I was the platform to go back up from how far it went down when the user steps out of the trigger. (It doesn’t go back up)

Any help on this would be wonderful as I’ve literally wasted hours trying to figure this out…

Sample picture: http://imgur.com/iDfjmTE

Do you use UDK or the UE4? -> because your picture is from UDK ^^

I assumed they were by the same company, so this forum would be where I asked about UDK July 2013… Was I wrong?

Yep, they are from the same company, but this forum is just for the UE4 :slight_smile: Here is the official UDK forum where you can get support from UDK guys: https://forums.epicgames.com/forums/366-UDK

(But of course when I can answer the question I will also do it in this forum ;))

@ Pured which collision type are you using? So how have you made your collision?

Thanks, I checked out that website too now.

As for the collision type I am using, I tried models that my modeler made (collision) made on another program which works fine (until I do matinee).
However, that model started disappearing when I did matinee, so my teacher suggested I use the ingame models since they don’t disappear. I tried a few of them, I tried making copy of the models and changing their properties/collisions, and at least this time it doesn’t disappear, but there is still 0 collision with it. (It has perfect collision before I put matinee).
I think I have tried every option that mentions collision, but as soon as matinee is added, the collision is gone.

The only thing I can think of is that when I convert the model to a “mover”, it loses its collision. I have tested it, and that is the case, So now I add the collision back into it “Block_All” after making it a “mover”. Now it has the collision, but it disappears instead of moving… It’s driving me crazy.

I will try it out for you with one of my own meshes :slight_smile:

Create your model in your 3d program
create a collision mesh (UCX_meshname) -> https://www.youtube.com/watch?v=a4CP7cpSqrE
import it
place it
right click onto it -> convert -> to mover
with the mesh selected press F4 -> change the collision to block all
now with the mesh selected create a matinee sequence e.g move it down with the movement track -> how have you animated it in matinee?

  1. change the max trigger count to 0 or 2

In my case it works perfectly ^^

Ah yes, forgot to put trigger to 0.
However, the model (including the collision) disappears.

I will make a video and put it on youtube in around 2 hours. (doing an assignment right now)

Here is the video showing what I do. (tried this with both my models and the UDK sample models) Sorry my mouse isn’t recorded, but you can still see what I’m doing.

First run = collision is there, model doesn’t disappear.
Second run = collision isn’t there, model doesn’t disappear.
Third run = collision is there, model doesn’t disappear.
Fourth run = forgot to attach the kismet.
Fifth run = collision is there, model disappears.

Video: https://www.youtube.com/watch?v=voHAVBMunAs&feature=youtu.be

Hmm, very strange.

  1. try it without a delay
  2. change your gamemode to DM
  3. could you probably upload the mesh somewhere so that I can take a look at it?

1- I have, it is the same thing, the problem is with the matinee, not the trigger/delay.
2- I tried, made no difference.
3- Loading...

Hmm, I dont get a problem when I try it with your mesh. I just created the collision in blender (just copied the mesh -> named it UCX_name) -> imported it -> placed and converted it to a mover + set the collision to block all -> then I created the matinee

Oh wow. I tired yours and it worked.
Then I try and move the mesh into my .upk → convert to move → set collision block all → matinee… and then it disappears when I step on it…

I also added the Attach-to-actor thing, thought that might make a difference, but it didn’t.

Do you always move it into a special package and is that package probably not in the content folder? + click fully load before you use it

Yes I always fully load it.
I sent it to my group for them to try it out.
It might be my computer(Maybe).

Ok, make sure to post the solution/reasone when it works after they tried it out :slight_smile: Otherwise you can also add me at Skype so that you can send me your package and map (of course without all other meshes) -> nasph96 (Philipp)

Yes, thank you for all your help.
If we end up getting it to work, I’ll post the problem here.
However, we’ve decided if it doesn’t work, we will just do the level without moving platforms.

It’s been solved.
I was hoping that this wasn’t the issue, but it was.
When the model hits a kill Z boundary, it disappears.