Download

Still can't run tappy chicken

Edgaras.Randi, can you post this to answerhub? Thanks!

RCaloca, thanks. For someone who will come with the same problem: https://answers.unrealengine.com/questions/52975/android-43-launching.html

There were some fixes for Tappy Chicken launch that didn’t make it into 4.2 unfortunately but will be present in 4.3. Are you able to grab the latest from GitHub to test with that by chance? If not I’d like to put you in touch with one of our folks working on Android compatibility to make sure we get the issue figured out.

I have the issue too, I was trying to run it, and another projects, but allways getting a black screen and closing, even when tappy chicken from marketplace works fine…

I just grabbed UE4 4.2.1 and downloaded Tappy Chicken. I compiled it for my Android Device, which is a Samsung Galaxy S3 I9300 and Tappy Chicken runs fine in Debug mode and ATC. If I open the Dev Console on the Smartphone, it says, that it uses ETC1, but anyway.

EDIT:

I have to correct it a bit. Somehow entities which are defined by Fonts, like the count for the passed obstacles, are not being displayed on my SGS3. On another hand, I have to inform you, that my SGS3 is rooted and has the Android Ice Cold Project ROM installed, which is based on Android 4.4 KitKat. Might be the issue, since another App also has display issues with certain font types.

Same thing here doesn’t work an a Samsung Galaxy S3. I just took the 4.3 source from github and want to compile it. I just need to know the right steps to take firts.

#1 -> build with “Development Editor” - “Win64”
#2 -> rebuild with “Shipping” - “Android”

→ this is where i don’t know what to do. The #1 step is to simply compile the editor itself and make it work. Now to be able to test via direct install to the phone or uploading a signed APK to Google Play Developer Console I need to rebuild/build a Shipping - Android I assume but I can’t find any answers or documentation about this subject. Even Epic’s video on YouTube only shows the “Development Editor” - “Win64” build but nothing is mentioned about rebuilding/building it for other platforms what so ever.

If anybody has info on this I would be glad to hear/read it. This again shows that Epic isn’t sharing it’s resources to be honest. It said tappy chicken was shipped with the 4.2 build, we are on 4.2.1 and still can’t get AdMob and Gamecenter to work. Imho they should push a fix for this. As a indie developer not being able to run ads or gamecenter or even have the functionality to test it is a big big error on epic’s side.

Hi KillerSneak,

You shouldn’t need a Shipping configuration for testing, it’s only needed when you want to get a better idea of the final file size, and to submit to the store, and even then you only need a Shipping game target and should use Development Editor for the Editor (e.g., “Shipping” + “Android”, and “Development Editor” + “Win64”). To change configurations, use the “Solution Configuration” dropdown in Visual Studio, and to change platforms use the “Solution Platforms” dropdown. One or both of these might be hidden by default in Visual Studio Express, I don’t remember exactly.

We tried to be as transparent as we could RE: what was shipped and when:

Cheers,
Michael Noland

The TextRenderComponent was using 32 bit index buffers, which is an optional feature for OpenGL ES2 and isn’t supported on all devices. This was fixed in CL# 2078450 (which missed 4.2 by a few days but will be in 4.3) to use 16 bit index buffers. I can try to dig up the GitHub equivalent changelist if you are building from source.

[EDIT] Here is the commit to master: https://github.com/EpicGames/UnrealEngine/commit/2e07d2efa5580af6080d55c33769f7cf21affcb1#diff-8ffcc4eb9ec7dc5987d8866ea283f337

Cheers,
Michael Noland

Any idea/information about the official 4.3 release?

We were aiming for RC0 today, but I think we missed by just a couple of bugs. After our first release candidate, it typically takes one to two weeks to hit a final candidate, do all of the launch prep stuff, and get it out the door. No promises, but mid-July seems realistic.

Cheers,
Michael Noland

Thank you for pointing this out, Michael Noland. I am currently using the Launcher and the pre-build Bin version from UE4 4.2.1, but I can also clone the Git source and compile the 4.3 Preview and check out, if it is fixed on the SGS3 :slight_smile:

Thanks for the info although I really doubt this problem will be fixed. 4.2.1 runs my game fine 4.3 doesn’t (only a black screen) Is there any info I can supply to get this fixed / help the progress in fixing this problem? I rebuild the source today so it’s the 4.3 version from 09-07-2014 with the latest commits.

Hi KillerSneak,

Sorry to hear that it’s not working with 4.3. Do you see anything in the device log indicating a crash or failure to load/compile a shader or something, etc…? That’d be the first step I’d try, and I’ll ask around to see if anyone knows about any outstanding S3 issues.

Cheers,
Michael Noland

Heya,

There is an outstanding bug for 4.3 with GooglePlay that is being looked at right now:

Cheers,
Michael Noland

I first tested on Android 4.04. When I installed Tappy from an SD card I get a blank screen, then it dies. When I installed it over USB using the included .bat file, it popped up a message box saying GooglePlay needed to be updated. I updated GooglePlay, and it crashed again. Finally I uninstalled GooglePlay and it worked.

This is only my first month with Unreal 4 Engine and I have to say I am very disappointed by the lack of professionalism in this area of the program. Your Editor is top-notch, and you engine is the best in the market, but you completely gloss over the most important part, getting the darn thing distributed. You don’t seem to have any video tutorials on packaging, your manual is also lacking in this regard. If anything, this should be your biggest focus, because the indie market can’t survive on PC alone. I hope you guys get this working very, very soon.

Just got a notification on this thread. First of all, I wasn’t able to run any of the demos of unreal on the phone gs3-4.3 android, second of all, there was a rumor that samsung released a faulty version of android: https://community.verizonwireless.com/thread/812849 . For my understanding it only concerns samsung devices. Report log of full program startup in the first post: http://pastebin.com/3r1nwR4h .

This is really frustrating isn’t it? I can’t get anything to work, even a Blank project to work on any of my Android devices. Nobody from Epic really wants to help either.

Edgaras, I noticed this on your log: Couldn’t find Shader TBasePassForForwardShadingVSTLightMapPolicyLQLDRGamma32 for Material Resource WorldGridMaterial!; are you building from source?

If you mean by engine source, then both. With source compiled by myself and executable that comes from unreal launcher. Can’t remember just if the log is from my compiled version or yours.

If it gives any more insight clues, the phone model is European, gt-i9300

Can you guys tell me where to find the log files so I can take a look as well ?

@ Michael Noland If I disable the Gamecenter polling will it work then? I’m now downloading the latest master source as the last 4.3 source (including commit of today) doesn’t compile anymore and gives a ton of errors and will

Fix the problem for now?