Download

Stereo on console command giving me different results

I’ve been exhaustively making tests today to increase the fps, and came across a weird situation:

On my demo, every time I start it, I press ALT+ENTER to switch to the Oculus, and it runs fine. After some tests I decided to automate this, and created an “execute console command” node with “stereo on” on the level blueprint, connected to an “Event Begin Play”. This works fine, and I noticed how suddenly my demo had an increase on fps. I made some tests regarding this situation:

Using “hmd sp 100” with nvidia driver version 344.11:
Test with “stereo on” from blueprint: 67.46 fps
Test with ALT+ENTER: 67.96 fps

Same test with nvidia driver 347.09:
Test with “stereo on” from blueprint: 54.76 fps
Test with ALT+ENTER: 51 fps

Using “hmd sp 200” with nvidia driver version 344.11:
Test with “stereo on” from blueprint: 33.8 fps
Test with ALT+ENTER: 26.3 fps

Same test with nvidia driver 347.09:
Test with “stereo on” from blueprint: 28.9 fps
Test with ALT+ENTER: 23 fps

Using “hmd sp 90” with nvidia driver version 344.11:
Test with “stereo on” from blueprint: 68 fps
Test with ALT+ENTER: 74 fps

Same test with nvidia driver 347.09:
Test with “stereo on” from blueprint: 59.4 fps
Test with ALT+ENTER: 56.3 fps

All tests were made using the fraps benchmarking tool along with FLACalculator. This may introduce some decrease in performance, and that’s why I made these tests also without it, just to confirm that the ALT+ENTER (or inserting the command “stereo on” after the demo has started) decreases the performance, BUT it increases the image quality: it makes it sharper than the other option.
I also tested on the blueprint inserting a small delay before turning on the stereo, and the result is the same as using ALT+ENTER, so I can assume there’s something about the load order.
I can’t quite make it what it may be, but it has to do with the image blurring. It’s weird because it’s almost the same effect as decreasing/increasing the screen percentage, without doing it.

Also, it’s quite clear that the latest nvidia drivers are worse, at least for UE4 VR.
In some cases, it’s strange that there isn’t any apparent change (such as the very first example).

I’m using windows 8.1, GeForce GTX 770, UE4 4.6.1, and the Oculus SDK 0.4.2. I found that the latest Oculus drivers give me other issues and instabilities.

“Stereo on” doesn’t change the resolution (at least in that version) while Alt-Enter does it. So, if the window resolution was anything but 1920x1080 then Alt-Enter and ‘stereo on’ command will give you different results.

In 4.7 (or 4.6 + 0.4.4 integration available from https://github.com/Oculus-VR/UnrealEngine/tree/4.6 we added ‘stereo hmd’ command that basically does the same what Alt-Enter does (in Extend mode - it will resize and reposition the window; in Direct mode it will change the resolution of the rendertarget while keeping the original window dimensions).