Download

StaticMesh Keeps going black after building light

So i have been having this issue where my mesh goes black after i build the light.

Here is what i tried

  • reimport the mesh
  • delete all light and use the one from the default level
  • set light map resolution to 64 and light map coord index to 1

All of the above did not fix the issue

I get this warning when i build light : No importance volume found and the scene is so large that the automatically synthesized volume will not yield good results. Please add a tightly bounding lightmass importance volume to optimize your scene’s quality and lighting build times.

this mesh is really big but all other small mesh have correct light.

Here is before

Here is after

This is my outliner

Do you have a proper UV for lightmap?
If enabled, these are built while importing the FBX into the engine.

Ah, just saw your comment with the resolution + index change:
You may check, if the UV inside Channel 1 is suitable for the Light Map.

1 Like

Hi, I had the coordinate index set to 1 but my UVs were on channel 0, I changed it to 0 and I am building light now will edit this when its done building.

Normally Channel 0 is the UV map you create with the 3D program before importing the asset into the engine. The automatically generated UV Light Map is on Channel 1 (most of the time) and is used for light baking. So if your Channel 1 is empty, something went wrong with the automatic process and you may have to review your original UV map?

I can’t edit the original UVs they are made in a special way where allot of them are overlapping but the overlapping UVs all have different materials, this is a big terrain with lots of details so making UVs smaller is not an option. but selecting channel 0 did the job, it might not be the best but I will stick with this since it works.

Ok :slight_smile: If it works, it works.

I’ve never used it before, but there is an option to build another Light Map for the Asset inside Unreal Engine. There are also a few options which may get you a proper layout. Just in case you face more troubles :slight_smile: