[Static Mesh] Simulate Physics options doesn't get enabled

My objective is to drop off objects ( ex: wallets, mobiles which are static meshes) from a certain height and let them land on other objects in the scene ( like sofa, dining table which are also static meshes). While I’m able to enable the ‘Simulate Physics’ option for some static meshes, for others, this option is greyed out. So when I drop my wallet asset on my bed, it simply goes through my bed and lands on the floor. But the wallet lands on top of the sofa (which has Simulate Physics enabled). Can someone help with this?

Is there a easier way to block collision for my ‘bed’ like objects ?