Download

Static mesh insists UVs to light map are overlapping 50% when they are not

This is driving me nuts. I have a simple hall mesh that refuses to build lighting without the overlapping UV light map error. The textures are on channel 0 and the lightmap UVs are assigned to channel 1. Checking the UV layout for channel 1 shows the UVs are not overlapping. The mesh has the light map coordinate index set to 1. Despite this, Lightmass insists the UVs are overlapping. Checking the Error Coloring shows the entire hall has overlapping UVs. I already checked to see if the polys were doubled and they are not. I’m starting to think this is a bug. Any ideas?

Are you sure UE4 is importing your UV1 and it isn’t generating a new lightmap? Double check the static mesh import setting and the UVs in the static mesh editor.

Are you getting lighting errors on that static mesh model when you bake lighting (visible errors, not just the text warning)?

I found the problem. It was something stupid. The mesh had a mirror modifier set on it that was creating a double mesh. It’s the dumbest things that cause you the most grief.