Download

Static Mesh BP (Timeline) Greating Massive Hit on Performance

Hi All,
I have imported a machine from my mechanical design software (Inventor) through 3DS Max into UE4. No real issues (after a lot of optimization) and it runs silky smooth while walking around and viewing - head tracking is good and I’m achieving a solid 75fps (CPU load around 76%, GPU load around 83%).

Image1.jpg

I now wish to animate some components to simulate the machine running. I have started with 2 simple BP’s on a static meshes to get started. (One shown below, other similar.)

Image2.jpg

These assemblies now move as expected but the hit on the frame rate is severe, I am fluctuating around 55-75 fps and the GPU load max’s out!

I have looked through many posts here and from what I can gather it could be the change from being a non-moveable static mesh to a moveable ?

Is the hit on performance really that severe, or am I approaching this the wrong way?

Is there anything I can do to the meshes to help?

The room is a simple box from BSP’s and I have 3 lights of which only 1 is casting shadows. I know I have some areas where I can reduce the mesh density and cull some faces etc. Though nothing that I believe would get me down to a level where I can have enough moving parts to give full machine simulation if the hit is this great with just 2 moving parts.

Any advice or pointers would be greatly appreciated.
I’m very new to both UE4 and 3DS Max, this is my first project using either piece of software.

Hardware.
DK2
CPU - I7 4790K
GPU - 780TI
RAM - 16mb

This is just a hunch, but are the meshes set to Movable or Static for their mobility setting?

Again just guessing here, but it may be that setting it to Static and then changing the transform at runtime is hitting certain overhead in the physics system related to moving static collision actors.

Thanks, yes I have only changed a few meshes to moveable from static. Just the ones I actually want to move.

I am getting much better results now, I had mistakenly assumed that as I was just working in an enclosed room the sky sphere, atmospheric fog and outside directional light (from the FP template I based my level on) wouldn’t be impacting my frame rate!. As soon as I deleted them my loads went back down on both GPU and CPU. I am now able to start animating things without as yet any severe drops, just keeping my fingers crossed I can keep it within the threshold.

I am learning that removing redundant objects and severe optimization is the key with VR.

Make sure to reduce almost all of your post processing when in the rift mode. See couch knights for an example PostProcessVolume. Real-time reflections (use static scene capture actors instead), motion blur, etc all cost too much due to double rendering cost.