Static lighting on SpeedTree models

I downloaded the free SpeedTree examples for UE4 and placed it on the default
level. Created a lightmass importance volume and built lighting.

Any tips how to fix this in Unreal, without the ST modeler?

You mean the black shadows? -> just add a skylight and disable “cast shadow” :slight_smile:

I expected the result to be smoother, more even, this looks broken. Turning them
movable makes them look proper but then they are not contributing to GI and look
disconnected from their surroundings when not lit directly. I guess I can place
one static, hidden in game tree and a movable one at the same location.
Well, I’m just trying to get a feel for what can be done in this area.

Have you already tried to use a higher lightmap resolution? -> double click onto the tree - in the static mesh editor under lightmap resolution you will have to add a higher value -> e.g 128
Also make sure to use a higher lightmap resolution on your ground :wink:

I did try setting the lightmap resolution under “Static Mesh settings”. As it turns out that
alone is not enough: In each LOD step the “Build settings” needs to be adjusted too. By
default it generates a lightmap UV for a 64x64 map which layout is wasteful when higher
res lightmaps are used. (That’s why I only saw marginal improvement when setting lmap
res to 2048 on the tree. :slight_smile:

“Min lightmap resolution” at 256 makes things look great. Thanks for the help!