Download

[SOLVED] Oculus Remote controller not triggering any input event in 4.17.1

I am trying to double check if others are also experiencing issues with handling the Oculus Remote controller within their VR applications. It used to work fine until version 4.15.x (and probably 4.16.x, but I haven’t tested it) and it still does with the already released applications.

Now with 4.17.x I am unable to get any input from the Oculus Remote. I tried also to switch it to native mode (vs. Gamepad emulation) but still I don’t get any event from it (e.g. Gamepad Special Left or Oculus Remote Back).

I know that the remote works properly because I can use it within the Oculus Home and our old applications on 4.15 still work fine with it.

Could someone else please confirm that you are having the same issue? Or do you know a way to make the Remote work on 4.17.x? (including altering the source code and doing custom build)

I have pointed this issue out both on Answers and on the Unreal Oculus forum. No help so far.
https://answers.unrealengine.com/que…ed-in-417.html
https://forums.oculus.com/developer/…rplugin-1-1-50

Background info: we have developed a number of VR experiences that require an expert to guide the user through them. The applications are designed so that the expert uses the Oculus Remote to make some choices for the user. The user then interacts within the experience using the Touch Controllers but the expert can always jump in and make corrections if necessary.

Thanks!

Cheers,
Marco.

Ok, never mind. It turns out it is a bug in the OVRPlugin. I have fixed it and created a Pull Request for it.

Cheers,
Marco.