Download

[Solved] Are these build times normal with these specs?

Hi everyone, I’ve just started Unreal and liking it so far. But the build times take too long (240ish seconds, small project) after modifying 15-20 lines of codes. Here is the Visual Studio output:



1>------ Build started: Project: CoopGame, Configuration: Development_Editor x64 ------
1>Parsing headers for CoopGameEditor
1> Running UnrealHeaderTool "E:\Unreal Projects\CoopGame\CoopGame.uproject" "E:\Unreal Projects\CoopGame\Intermediate\Build\Win64\CoopGameEditor\Development\CoopGameEditor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -abslog="C:\Users\iTopya\AppData\Local\UnrealBuildTool\Log_UHT.txt" -installed
1>Reflection code generated for CoopGameEditor in 11.9525005 seconds
1>Building CoopGameEditor...
1>Using Visual Studio 2019 14.26.28805 toolchain (C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801) and Windows 10.0.18362.0 SDK (C:\Program Files (x86)\Windows Kits\10).
1>Building 9 actions with 16 processes...
1> [1/9] CoopGame.init.gen.cpp
1> [2/9] SGrenadeLauncher.cpp
1> [3/9] SGrenadeLauncher.gen.cpp
1> [4/9] SWeapon.gen.cpp
1> [5/9] SCharacter.cpp
1> [6/9] SWeapon.cpp
1> [7/9] UE4Editor-CoopGame-0050.lib
1> Creating library E:\Unreal Projects\CoopGame\Intermediate\Build\Win64\UE4Editor\Development\CoopGame\UE4Editor-CoopGame-0050.lib and object E:\Unreal Projects\CoopGame\Intermediate\Build\Win64\UE4Editor\Development\CoopGame\UE4Editor-CoopGame-0050.exp
1> [8/9] UE4Editor-CoopGame-0050.dll
1> Creating library E:\Unreal Projects\CoopGame\Intermediate\Build\Win64\UE4Editor\Development\CoopGame\UE4Editor-CoopGame-0050.suppressed.lib and object E:\Unreal Projects\CoopGame\Intermediate\Build\Win64\UE4Editor\Development\CoopGame\UE4Editor-CoopGame-0050.suppressed.exp
1> [9/9] CoopGameEditor.target
1>Total time in Parallel executor: 224.65 seconds
1>Total execution time: 237.59 seconds
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========


This is the first compile I did after opening the project. Tried one more compile after this one, changed only 1 line in a class. Took 3.5 seconds which I think is good enough. After that, 15-ish more lines of code modified. took 15-20 seconds. Are these normal with my specs? Thanks!

CPU: 3800X
GPU: 2070 Super
Memory: 16GB 3600Mhz
Project and Unreal is on HDD, Visual Studio is on SSD.

[Solved]

**The solution is pretty simple. Moved Unreal Engine and Project Files to the SSD. This fixed a lot of waiting time. The editor now loads in less than 10 seconds, (used to be 30ish) and the same compile I did above takes 6 seconds instead of 240. Also, I’ve added all unreal engine, visual studio and project folders to the ignore list of antivirus. **