Download

Smoothing Problems With Simlabs FBX Import

Hi,

I’m new to UE4 and to this forum. I’ve tried doing a few searches on my shading problem but without luck so far.

I’m using Simlabs FBX exporter to move export models from Sketchup 8 to UE4.14.

Generally it is OK but I’m having problems with smooth objects such as cylinders which appear smooth in Sketchup but faceted in UE4. I check with Simlabs and they tell me that their exporter doesn’t export smoothing information from Sketchup 8.

So my question is can I smooth a mesh asset in UE4 - or do I have to figure out the smoothing before I import into UE4 ? - I’ve tried re-computing normals and tangents in the UE4 mesh editor but it didn’t make any difference.

Many thanks.

Cheers
Paul

UE4 has some smoothing options in the FBX Import window, it can try to calculate smoothing but it doesn’t necessarily do things the way you want which is why it’s better to get it exported to FBX with correct smoothing. If the smoothing options in UE4 aren’t doing anything, maybe the file is ending up with each polygon split from the other in which case they can’t smooth together.

Hi,

When I export from Sketchup to 3D Studio Max the polygons get split from each other so I bet that is my problem - it would make a lot of sense - I’ll see if there are any options that prevent this happening. I suppose I could refine the model in Max then use the Max exporter to go to UE4 - I was just trying to find a way of minimising the export steps required - I’m using Sketchup btw because although less powerful it is just quick and easy to use for simple models compared to Max.

Many thanks for the quick reply.

Cheers
Paul