Download

Small fast moving objects are not visible with TAA

TemporalAA:
TAA.png

FXAA:
FXAA.png

Any suggestions?

Wait for UE4 to have a proper TAA or that they implement/pull MSAA :wink:

Disable AA or switch from TAA

I have a dream that one day, UE will have a good AA solution.

You mean like the ones that are in there now?

There already is a solution specifically for this issue, simply go to the particle’s material and turn on “Responsive AA” under the advanced options of the translucency section.

I haven’t tested it for a long time but i remember it still caused issues with small particles disappearing on TAA, I think last time i tested it was sparks but it was causing issues on details of shader based / geometry particles too, It would reduce detail.

edit: good to know that its fixed

Except that it blurs the **** out of the particles and whats behind them. But better than nothing.