Download

Skylight issue

Hi all,

I’ve an issue with Skylight.
Here are 2 screenshots of what I mean. Look at the white light at the bottom of the wall.

Without the skylight :

With the skylight :

The quality light build is set to Production. The wall’s lightmap resolution is set to 512.

Are these custom Wall static meshes or ones provided with the Starter Content?

Assuming here that these are custom static meshes.

This looks like you’ll need to fix your Lightmap UVs so that the hard edge vertices are placed on a grid alignment when you’re making your lightmap UV. Otherwise you can get some bleed like this.

When setting up your LM UV you’ll need to decide on a target resolution (Personally I use 64 as my base when starting with a wall because I can scale up and it will still be on the grid, ie 128, 256, 512).

To find the grid spacing resolution you’ll want to do the following: 1 / [Target LM Resolution] = Grid Spacing ie. 1 / 64 = 0.015625

This will be your grid spacing. Make sure to snap the corner vertices to the grid. This will help with the light bleed you’re seeing.

If you have any questions feel free to ask.

Tim

Make sure your walls are thick enough, usually 6 inches.