Download

Sketchup into UE4 UV Overlap

Hi guys, I’m faily new to UE4! I’m working on several scenes for archviz where the meshes have been created in sketchup. UE4 imports the textures in beautifully but when i go to rebuild my scene lighting I receive the UV overlapping error and the textures go wild and start tiling. I know sketchup doesn’t have a UV editor so how can I get the lighting to work and remove the error while getting the lighting results i need?

I have seen someone say that I can generate unique UV’s but i get an error, attached.

Sketchup to ue4. welcome to hell. Probably the worst workflow ever imo.
Ue4 will generate a lightmap UV on import, based on the texture UV…so no texture UV, I doubt Ue4 will make you a lightmap UV.

Bring sketchup to 3dsmax, make texture UV, export to fbx, import in ue4 and click auto generate lightmap UV…still a bad workflow. I would not expect much out of it tho!

Good luck my friend!

****! Bad news so! I ve trying this (export fbx to 3ds max, applying uv add modifier, importing to UE 4.7 as fbx) and can’t solve the problem. In the editor everything just look good. But when i buil the scene… everything drops down! I m really frustrated :,(

when you import your models into UE4, a couple things could be happening. things look fine in the editor because you’re showing dynamic light. when you bake light, you’ll see your problems until you null your baked solution by moving a light or something. if you already have a lightmap index in 3d studio, but you keep the auto-create option on during import to UE4, you will end up with 3 channels total ( 0 = base, 1 = lightmap, 2 = alternate lightmap), so make sure you use the right one. in your static mesh properties in UE4, that your index is set to either 1 or 2 depending on which lightmap set you want to use. sometimes during this pipeline the autogenerated unwrapping for lightmaps is a little better than the flatten in 3d studio, or vise versa. Also, if you don’t break down your model into chunks, you will need very high resolution lightmaps to get the fidelity you’re looking for. so if for some reason you want to import a huge complex object as one object, increase your lightmap resolution, but know that it’s pretty taxing on a light calc.