Download

Skeletal Mesh LOD problem

Thought I’d post this and save someone else the same headache.

I was working today with a skeletal mesh and had added LODs to it but was getting a seriously scrappy display on LOD 01 and LOD 02 that I couldn’t figure out at all.
LOD 00 displayed perfectly but LOD 01 and LOD 02 had the really bad shading and facetting that shows in the image below. All LODs were perfect in 3DS Max and the same materials were being used on each.

LOD 00 and scrappy LOD 01 (LOD 02 was the same)
after importing LOD 00 at 10.0 scale.

After much faffing about and redoing the LODs twice using different methods I noticed that the import scale for LOD 00 was set to 10.0 - the original model wasn’t created at actual size in 3DS Max. When I changed that to import at scale 1.0 the problem disappeared, an easy fix but it took me a long time to spot it! I now have a teeny wee shark but it’s easy enough to scale him up now that he’s in…

LOD 00 and LOD 01 displaying properly after re-importing LOD 00 at 1.0 scale
(LOD 01 and LOD 02 had to be reimported as well)

When importing LODs for static meshes, if it’s at a different scale then the different sized meshes are obvious in the editor. With skeletal meshes it looks like added LODs are being imported at their original size and not at the import scale for LOD 00 but Instead of displaying smaller they must be getting stretched to the same scale as LOD 00 with their lightmap at their original 1.0 scale instead of 10.0 scale - no idea, just surmising but importing LOD 00 at a scale other than 1.0 is having some kind of effect on the added LODs and it’s not a pretty one.

Would seem to be more ‘intelligent’ if the engine imported the LODs at the same scale as LOD 00 is imported at? Or at least you should have the option to set import scales for LODs if you need to control it for whatever reason.

Anyway, use import scale 1.0 for LOD 00 if you are going to add LODs to skeletal meshes.
:rolleyes:
:slight_smile: