Skeletal Mesh import broken? Triangles missing


I have a big problem when importing edited fbx file from blender inside UE. I have seen many topics about this issue but never have found any solution so I wonder if any of you have dealt with it already.
All I needed was to add different materials to lights on car and etc. so I exported the skeletal mesh from UE to blender (if you know any other options on how to do that please spare me the whole blender thing), added the materials I wanted and then exported into fbx again. When exporting the fbx back to unreal engine the mesh is broken. A lot of small triangles are missing (pic 1).

I have tried like everything, every single export setting in blender (even though opening the fbx file in other editor or fbx previewer seems always good), I have also checked the faces - they are ok.

From Unreal perspective, I also tried every single possible setting there is when importing this fbx and could not find what was causing the problem.

What made me wonder though is that I tried to upload the original fbx file to unreal (which was ok), also to blender and exported it without changes (also looked ok in 3D previewers and other editors) but importing it again into unreal even unchanged broke it again.

I really do not understand what is going on here, so I beg you for your help guys :frowning:

Thanks for reading, I´ll be looking forward to your answers!

Okay so since after 3 days of trying to figure this one out I could not find any answers, I decided to remove the skeletal mesh provided by the seller I bought the asset from (ended up with static mesh).

I imported the static mesh into the blender and rigged it using this tool (UE4 Vehicle Rigging Addon for Blender) really fast, added materials I wanted and there was no issue anymore. Which is weird but worked for me.