Skeletal Mesh fingers problem

Unreal Version: 4.15.1-3348071+++UE4+Release-4.15

Blender Version: 2.78c

I am in the process of testing my Blender to Unreal pipeline and have become stuck with a problem of fingers leaving their parents. For testing purposes, I have removed all keyframes from the fingers, so their should not move. Still, when I import, and preview the animation, the last 15 frames, they rotate on their own like this:

(Observe the character’s right hand; the hand in the left side of the image).

These are my export settings:





It would appear that adding some rotation keyframes further up the hierarchy solved the problem, or at least mitigated a lot of the problem. Why this is, I don’t know. Seems like a bug.

what do you mean by adding some (rotation) keyframes further up the hierarchy? how do i do that? :slight_smile:

this is maybe a solution for one of my problem’s: Bone axis/rotation problems (from blender to UE4) - Character & Animation - Unreal Engine Forums ;D

I don’t recall completely what turned out to be the issue. Looking at your issue, you seem to have solved yours - congratulations!