Skeletal Mesh - Blender to UE4 - deformed animation


So it’s another one of those: basically after exporting from Blender and importing into UE4, my character’s animation comes out deformed. I’ve looked through tons of threads with similar issues, but so far nothing has worked.

To start of with, here’s images of basically the same frame first in Blender, then in UE4. The problem should be apparent (the lower arm is deformed in UE4 while in Blender it looks fine):

I’m using Blender’s Rigify, which exports a few non deforming bones here, but I don’t think it’s related to that really since the bones come out fine. But something about the weights is probably just off. I tried normalizing the weights, maximized the influencing bones per vertex to 8, removed all vertex groups with weights of < 0.01, but nothing makes a difference. Also, the weights look fine in Blender, very smooth borders, no apparent bones with weights they shouldn’t have (I looked through all vertex groups)…

I suspected it might be something within Blender’s fbx exporter so I tried both 2.79 and the 2.8 beta. I tried exporting from Blender and importing back into Blender, but it all still looks perfect until I import into UE4. In 2.79 I tried using RigifyToUnreal, which exported my skeleton fine with only proper deformation bones, but the problem remained.

I’m using the default options for UE4’s fbx importer, except without importing materials.

In Blender’s fbx exporter options, I ticked “Only Deform Bones”, deselected “Add Leaf Bones” and set smoothing to “face”, but that’s about it.

Any ideas what else could be causing this?

Thanks for taking the time to read this and have a great day!