Simplify issues

How do I avoid this happening when I simplify the mesh? The patches of flat colour appearing.

So to answer my own question (found the solution on a FB group) I needed to set the Large triangle removal threshold from 10 (the default) to 1000 in the Default unwrapping parameters in colour and texture settings. Then re run the texturing function and presto. it’s sorted.