ATM FVector has ZeroVector, UpVector, and ForwardVector. Maybe somebody just forgot to add RightVector?
Also, not sure who was the dev that is very verbose, but why not just call them Zero, Up, Forward, and Right? If you use them FVector::ForwardVector is just adds bulkiness to the code with no benefit.
You can easily add that by making use of cross products. Personally it makes things clearer to me as I know what ForwardVector is, even though it is part of the FVector class it doesn’t necessarily have to be a vector and could be referring to something entirely different. It could be a float, a boolean or anything else.
I know you can make it as a cross product (although it doesn’t make any sense to do so, it is just simpler to do FVector(0,1,0)), but they are the base coordinate vectors so imo they should all be there.
As for Forward instead of ForwardVector, it is a matter of reading what you have there, it’s a matter of context. FVector::Forward it is pretty easy to deduce that’s a Vector (1,0,0).
More useful in my opinion are the functions included in the Actor class which does include the right vector:
GetActorForwardVector
GetActorUpVector
GetActorRightVector