ShooterGameServer Target Configurations Missing

I tried making my own server target .cs file but after generating the VS project files the *Server configurations were missing in visual studio.
I figured I’d done something wrong so loaded ShooterGame and generated the VS project files for it but the same problem occurs even though there is a ShooterGameServer.Target.cs file in the Source folder.
Another thing to note: that file (ShooterGameServer.Target.cs) isn’t actually added in the VS project and is not referenced in the vcxproj files at all. It only exists in the filesystem.

Hello CrumblyCake,

Go into your project folder and right click on the .uproject file and select Generate Visual Studio Project Files. If you have the Target.cs file in the Source folder, doing this should associate the file with Visual Studio.

I probably wasn’t clear enough on this, but I already did this and it still wasn’t there:

after generating the VS project files…that file (ShooterGameServer.Target.cs) isn’t actually added in the VS project and is not referenced in the vcxproj files at all.

I also tried just manually deleting the generated files before generation and it still doesn’t appear or give the relevant configurations. And ShooterGame is untouched so the ShooterGameServer.Target.cs file is in place with the other target files in the Source folder.

Update: I also ran the .bat file in my 4.9 Engine/Build/Batch folder directly against the ShooterGame project with the same result.

Have you tried manually adding the Server Target file that is located in the project’s Source folder to the Visual Studio project by dragging it in?

I’ve found why it’s not working. I’m running Rocket and it looks like you don’t support server targets under it:
It also doesn’t look like you will support it either due to a subsequent increase in size of the installed engine:
A few hundred MBs for built-in dedicated server packaging seems like a good tradeoff to me :stuck_out_tongue:
But I recognise I’m a bit biased.