Download

Shooter game template

Hello.

I am using epics shooter game template and couple question about it. In Editor playing selected viewport there is shown my own HUD (it’s not ready yet) like screenshot, but when playing in Standalone, HUD doesn’t appear:

Secondly how i can remove unreal starting movie? and get playing time longer now it is basic 5mins. They are adjustable in visual studio maybe

Unreal movie has deleted and game time has now adjusted more longer. HUD and game start widget is little bit problem still. In fullscreen it works properly and everything looks ok, but when screen is smaller it looks like this (menu):

. Is there someway to “adjust” widget that it works in fullscreen and smaller screen window? if people understand what I mean

Most of problems get solved. But now when packaged my project there is still project own main menu. How i can get it off. If it solution to delete hole map. And when in my own main menu choose map to play it doesn’t open it

Can anyone say that How i can adjust player/bot respawn time?? Now it spawn every 5 second new bot/player to player start??

try editing the DefaultGame.ini file mine looks like this


[/Script/Engine.GameMode]
+GameModeClassAliases=(ShortName="FFA",GameClassName="/Game/UT40k/Blueprints/Game/Bp_UT40k_Deathmatch.Bp_UT40k_Deathmatch_C")
+GameModeClassAliases=(ShortName="TDM",GameClassName="/Game/UT40k/Blueprints/Game/Bp_UT40k_TeamDeathMatch.Bp_UT40k_TeamDeathMatch_C")

[/Script/ShooterGame.ShooterGameMode]
WarmupTime=5
RoundTime=300
TimeBetweenMatches=15
KillScore=2
DeathScore=-1
DamageSelfScale=0.3
MaxBots=1

[/Script/EngineSettings.GeneralProjectSettings]
Description=A example for a first person arena shooter game
ProjectID=579546EA410D974B63D30CAD69C686B4
ProjectName=UT40k
CompanyName=UT40k
ProjectVersion=410
ProjectDisplayedTitle=UT40k

[/Script/ShooterGame.ShooterGameInstance]
WelcomeScreenMap=/Game/Maps/ShooterEntry
MainMenuMap=/Game/Maps/ShooterEntry

you’ll have to change the “WelcomeScreenMap” and the MainMenuMap"

as for the spawn issue you best check what you have changed, sounds like you have done something to the ammount of bots max