Download

Shooter and RTS Game won't compile under 4.4.3

Hi,

I allready posted this on answerhubn, but since no one answers, I thought I shoulkd try my luck here. First of all, here is a link to the answer hub post, that basically explains my issues with ShooterGame in 4.4.3

https://answers.unrealengine.com/questions/117290/project-based-on-shootergame-not-compiling-under-4.html

I tried creating a clone of the StrategyGame Sample from the Market Place, but it wont compile either:

Error 2 error : Superclass AIController of class StrategyAIController not found D:\dev\Unreal Projects\RTSGame\Source\StrategyGame\Classes\AI\StrategyAIController.h 20 1 RTSGame
Error 3 error : Superclass PawnSensingComponent of class StrategyAISensingComponent not found D:\dev\Unreal Projects\RTSGame\Source\StrategyGame\Classes\AI\StrategyAISensingComponent.h 13 1 RTSGame

So I wonder if anybody else has tried compiling those and ran into the same issues or is it just my UE4 Setup? I am currently not subscribed to UE4, so I cant update to 4.4 or download an older version. However, I feel like it should be possible to run all samples in any version of the engine. At least some guidlines on how to get them working would be great. Is Epic planning on updating those sample projects? Would be great to know!

The problem isnt that I cant even open the editor of these samples, so i cant migrate content from them to use to prototype stuff.

Any help would be appreciated.

Thanks

This isn’t possible as there are code changes from version to version. You need the appropiate version to compile it successful, e.g. the version of the ShooterGame that is made for 4.4.3 (and not the one for 4.3 or 4.5).

Nvm, found it in the marketplace. Silly me. Thread can be closed :slight_smile: