Download

Shadow on the model has very obvious sawtooth

After baking the light, the shadow on the model has very obvious sawtooth. I have tried to increase the lightmap resolution and bake quality, but it doesn’t seem to improve,could u tell me how to fix the problem?Thanks a lot.

It would help to see a screenshot, but it may be due to your lightmap UV’s, if it splits it in a bad way then if your lightmap is lower resolution it could have some bleeding.

Noticed the same thing with 4k resolution for shadow in a custom model yesterday in .27

The bake wasn’t finalized.
Clicking inside pie and moving the camera made it look a little better.

Overall it’s still a baked shadow that doesn’t tile in an area where there’s 4 or more tile (8m) so I wouldn’t expect it to look perfect given the lightmap density.

Still. If you are letting unreal manage your lightmaps, the easy answer to your problem is “don’t”…

Oh,I’m so sorry that I forgot posting screenshots last night,I will post them later,could you take a look,thanks a lot :grinning_face_with_smiling_eyes:







Thank you,I don’t know whether the lightmap uvs that ue4 unfold automatically is correct,I just posted the screenshots and lightmap uvs a moment ago,could u take a look :wink:

It looks like you might be using static lights in which case your lightmap resolutions are too low. You would need to adjust the lightmap resolution on the objects that are receiving the shadows. However, if you intend to have dynamic objects in there, like characters you should switch to using Stationary lights. The difference is that with Static lights all lighting and shadows are baked to lightmaps whereas Stationary lights use realtime shadows for direct lighting and only bake the indirect lighting to shadow maps. Using Stationary lights allows for shadows from dynamic objects to blend with the shadows from static objects, though there is a limitation that you can only have up to 4 stationary lights overlapping a surface so you need to limit their range.

Also as far as making the lightmap UV’s, UE4 can’t make them entirely from scratch, the auto-generated lightmap UV’s option simply copies existing UV’s and runs an algorithm to flatten them out and pack them, it doesn’t work if your existing UV’s aren’t split well. From looking at your lightmap UV’s they could be improved if you did them manually but you might find a resolution that works without noticeable artifacts.
Generally the automatic UV options (like in 3ds Max where it splits the UV’s by an angle threshold) will require higher resolutions to look good because they often split things too much which results in some situations like you have there with very thin or small pieces.

I would also triangulation the model before export so that you don’t get the random face with a different orientation in the middle.
The UVs can definitely use work, but I don’t think that’s the reason for how bad the shadow looks.

There must be more to it.

Regardless, seeing all shadow maps to the same texel density would help keep thing looking proper…

When nearby assets shadow differently or with a gap, more often than not their texel density for the shadow map is not the same.
Check the optimization view mode. Make sure everything is in the green or redish-green.