Download

Setting weight in default section of blueprint editor?

Hey, I’ve searched for quite a while but have been unable to find an answer- No matter what object I edit (example objects, pawns, actors, etc) I cannot seem to edit the “Mass in KG” setting. I’ve tried with both physics enable and disabled, gravity, etc… I cannot find any setting that seems to affect it, and I’m wondering how to enable this setting or use another setting/parameter to edit the mass of objects.

And as a bonus question, if the mass of all these objects are zero, what parameter is being used to determine physics simulation (esp when force is being scaled by mass)? I feel like there’s a rather large chunk of information I’m missing here…

UE4 calculates mass automatically for you based on a few things:

  • The simple collision geometry of the mesh
  • The Density of the PhysicalMaterial applied to the object
  • The MassScale parameter on the instance

You cannot specify mass directly, but can influence it through these 3 things. The reason for this is that we also need to calculate the inertia tensor of the object to make it move correctly, and we do not want you to have to type in a mass for all objects in the world, its better if we can do it automatically for you. Did you trying adjusting the MassScale? If you are seeing 0 as the mass, that probably means you do not have any simple collision on the mesh. Here are some docs on setting that up:

I have not, and while I haven’t read through all of the documentation you linked yet (currently reading) that looks like it should solve my problem nicely. :smiley:

It might be worthwhile to put this information in a tooltip or something, as it seems difficult to find (not in documentation or on the wiki, nor could I find anything in the editor).

Thank you!

It was supposed to be on the tooltip already! I’ll make sure that gets fixed, thanks for the info.

Thanks for the info, this seems to work - but it appears that static mesh components in blueprints don’t have their Mass in KG value updated in the blueprint component editor, there it always stays as 0 for me - even if the static mesh in question will have a mass when simulated, or when added as a static mesh to the world. Took me a little while to figure out that they still had mass, it just wasn’t displayed…

Yep, we fixed that as well in 4.1.