Download

"Setting Up Dedicated Servers" tutorial, but online (not via LAN)

Hi everyone,

I’ve successfully implemented this tutorial, and tested it in a local lan setting, even checking the cross platform functionality so a PC and Android both can play together
https://docs.unrealengine.com/en-US/…ers/index.html

I then figured it would be a simple process to confirm this working online, at least in some hard coded fashion like in the tutorial. However, it has proven to not work when I try to take this project online.

Here is what I thought I had to do

  1. Port forward for port 7777 to my PC which will run the server
  2. modify Step “**3. Setting Up Entry and Default Maps” **step 3 to use my IPv4
  3. Launch game on android over my cellular connection
  4. Win

However, that has not worked. A little research on the topic has me thinking it might be easier to use IPV6, because I am using T-Mobile Home, and the are natively IPv6, and are only sort’ve emulating ipv4 for backwards compatibility. (“464 XLAT” for those interested). I’ve tried putting in several values for this ipv6, and nothing has worked. Formatting included

xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx

Unfortunately that has not worked either.

So I could use some advice on how to proceed. I do not care at the moment whether I use ipv4 or ipv6, my goal here is to learn. I am currently 50/50 on whether this is an ISP problem, but when I called their tech support they (not surprisingly) didn’t have much advice. They did say they helped people get their ARK game servers running, so in theory this should be possible…

  1. Does anyone have reliable method to simply check that incoming connections are getting to me? So far I’ve tried running a ftp server (filezilla), I’ve tried running a simple port listening program and https://canyouseeme.org/ (ipv4), a simply post listening program and (IPV6 Scanner | Online Port Scan), pinging (that is often blocked by isps though…) etc
  2. Does anyone know what the correct format for IPV6 is? I think I have it, but for whatever reason this is failing.
  3. I’ve attached sanitized logcat logs of both ipv4 and ipv6 attempts, maybe someone has an idea from the logs?

While I am a game dev, I am very very new to unreal 4, so this could likely be a “dumb noob” problem, but I’ve been trying to figure this out for days.