Setting up a FPS camera view

I’ve had this working in tutorials fine but with my own project I just can’t even get my character to stay on a floor correctly!

1)Play mode sees me being able to fly around yet in launch mode I walk around properly based on the input controls I’ve given it. Why is it different for each one?

2)I seem to start below the floor for some reason, yet do not fall?! So confused!

  1. My level blueprint has nothing in it. Could I be missing something that is causing this?

  2. Settings show I have my character BP selected as well as the maps. So it’s loading the correct character, I think. (There is only 1 character)

Put a Player Start in your level and make sure it is above the floor mesh.

I think I have? It’s that ‘pill’ shaped frame with a camera. My BP_Me (blueprint) has been placed in the scene and is above the floor.

It looks like this:

Alternatively, select your character in the scene and set Auto Possess to Player 0 in the details panel

Oh of course! Yeah I remember that icon from tutorials and confused it with what I had. Thanks so much.