Set Simlulate Physics ignores Set Actor Location (looking for a Workaround)

Hello, I have an issue with resetting my character Mesh after using the “Simulate Physics” Node.

I use Version 4.27.2

My problem is with the “death” of the Player. I have it set up so the movement gets disables, Physics get simulated and after a delay it puts you at your last checkpoint.

The issue: the Character Mesh stays where it fell. I can move around just without the mesh.

If I disable the “Simulate Physics” Node, it works as intended.

I have tried to find solutions to this problem but there never seems to be a viable workaround for my Situation.
Id be grateful about any suggestions to create a workaround for this!

Additional Info:

I simply replaced the mesh in the already existent ThirdPersonCharacter.

And I can use the respawn method of resetting the level, due to a day/night cycle which would reset to morning after every death which I don’t want

I have also already tried to move the second “Simulate Physics” which disables it to different positions in the Blueprint and none of them work

Here is the Image of my current Blueprint