ServerTravel not working properly

We have a matchmaking session, created by a server (a listen server) and joined by one or more clients.
Once joined, all the clients (and server) are correctly spawned on the map (the one chosen by the server).
At some point, the server wants everyone travels with them on a new map, so it calls the command “servertravel” by indicating the name of the new map.

If we perform it with the Null subsystem it works properly, and every player is spawned on the new map. The same is not true for the Oculus subsystem.
What we have is the following log:

[2017.10.19-10.10.16:027][880]LogNet: Browse: 1483781508382744.oculus//Game/Maps/Museo?game=/Game/Proteus_Multi/MultiGM.MultiGM_C
[2017.10.19-10.10.16:027][880]LogNet: World NetDriver shutdown OculusNetDriver_1 [GameNetDriver]
[2017.10.19-10.10.16:027][880]LogNet: DestroyNamedNetDriver OculusNetDriver_1 [GameNetDriver]
[2017.10.19-10.10.16:027][880]LogNet: UNetConnection::Close: [UNetConnection] RemoteAddr: 1483781508382744.oculus, Name: OculusNetConnection_1, Driver: GameNetDriver OculusNetDriver_1, IsServer: NO, PC: MultiPC_C_0, Owner: MultiPC_C_0, Channels: 39, Time: 2017.10.19-10.10.16
[2017.10.19-10.10.16:027][880]LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: [UChannel] ChIndex: 0, Closing: 0 [UNetConnection] RemoteAddr: 1483781508382744.oculus, Name: OculusNetConnection_1, Driver: GameNetDriver OculusNetDriver_1, IsServer: NO, PC: MultiPC_C_0, Owner: MultiPC_C_0
[2017.10.19-10.10.16:027][880]LogTemp:Display: ParseSettings for GameNetDriver
[2017.10.19-10.10.16:027][880]LogTemp:Display: ParseSettings for OculusNetDriver_2
[2017.10.19-10.10.16:027][880]LogTemp:Display: ParseSettings for PendingNetDriver
[2017.10.19-10.10.16:027][880]PacketHandlerLog: Loaded PacketHandler component: Engine.EngineHandlerComponentFactory (StatelessConnectHandlerComponent)
[2017.10.19-10.10.16:027][880]LogNet: UPendingNetGame::InitNetDriver: Sending hello. [UNetConnection] RemoteAddr: 1483781508382744.oculus, Name: OculusNetConnection_2, Driver: PendingNetDriver OculusNetDriver_2, IsServer: NO, PC: NULL, Owner: NULL
[2017.10.19-10.10.16:030][880]LogWorld:Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver

We compared it with the behavior of the Null subsystem, and the logs are the same. Also on the Null subsystem it continuously prints this last warning log, but after some dozens of them, all players are correctly spawned on the destination map.

It works if we use a Seamless travel, but we really need to use a non-seamless travel (other components have problems with the seamless travel).

May you suggest something?

Wish there was an answer to this, I see the exact same thing. Have tried LAN/Steam, in editor and separate machines, always does this. Interestingly in the editor if I call ProcessServerTravel(…) in c++ I still get the warning repeated over and over but it does eventually work.

I’m getting this error in 4.22 still. I am doing everything by the documentation and have been successful in setting up multiplayer for Steam in the past. Not really sure why this is happening…

Quoting from an answer seen elsewhere - ’ I found out that steam does not support server travel calls without seamless travel enabled and the error is exactly the same.’ So maybe the same is true of Oculus?
What is your problem with using seamless travel may I ask? Perhaps that is the problem that you need to solve.

I actually figured out the issue. I had already tried the seamless travel and every other option to no avail.

What eventually ended up working for me was this:

When you host the server, make sure to put “listen” in the options on the Open Level node.

Had the same issue, found an answer out there that reminded me to set seamless on the game mode for the travel map as well - fixed.