Download

Sequencer tracks should have "Keep State" enabled by default

Sequencer tracks should have “Keep State” enabled by default. Having everything snap back to the state it was before the sequence was played back isn’t really what you want 95% of the time, so to me it doesn’t make much sense that the default is for Keep State to be disabled. Maybe there’s some good reason why, but if not I think this should change.

I think is bug, something not implemented properly.
It works for me most of time, but sometimes not… Also hoping for quick fix, this issue kills me at every project.

And I gonna use this opportunty to link my friend’s report one more item :wink:
https://answers.unrealengine.com/questions/711312/sequencer-variable-dont-keep-state-after-finish.html

I noticed myself that the tracks have to be shorter than the sequence itself for keep state to work properly, you could check if that helps.

I’ve added the issue to our backlog of features. You can track it here when it becomes live:

Could you make it publicly visible? Thanks :slight_smile:

This answer helped us, maybe it will be helpful for someone else :slight_smile:
https://answers.unrealengine.com/que…er-finish.html

This should be default.

I have a sequencer spawning a bunch of cameras with image plates and I found when reopening the project the image plates had been removed from every spawned camera and now I have to go back and manually re-add them. I discovered the right-clicking the camera in sequencer and clicking “Save Default State” seems to lock in my image plates but this should really be the default functionality.

You can set default behaviour in Project Settings now.
The engine’s default won’t changed because of backward compability :wink:

I tried to find default behaviour for that and I wasn’t able to (UE 4.20.3). Both in Editor Preferences and Project Settings :frowning: Can you tell me where is it?

Well… maybe it never been exposed to UI.

I added this to DefaultEngine.ini


[/Script/LevelSequence.LevelSequence]
DefaultCompletionMode=KeepState