Download

Sequencer Render Metahuman Woes

Hi, is there a way to stop all this blueprint crazyness going on when i hit render sequence? I’m getting sick of this! For example at the moment I have a metahuman with an ‘animation’ sequence instead of a control rig on the body (ie in the sequencer not in the blueprint- it’s set to custom) and a face rig opening the eyes. Works perfect in the viewport. The eyes are shut throughout the the animation and then they open.

When i hit render sequence, there is some weird double transformation going on and the eyes start opening early. Why would this be? Why would some kind of different animation kick in at rendertime? Is there a button somewhere called ‘render only what you see in the sequencer viewport?’ It’s driving me mad!

I’m pretty sure this has something to do with the animation mode. If I select the face in the sequencer and toggle between it’s animation modes ‘Use asset/ Use animation blueprint etc’ it seems to recreate the issue I’m having at rendertime within the viewport.

If i click ‘disable post process Blueprint’ the eyes suddenly open, when they have been keyframed on the control rig to be closed. Why is this? Is this overriding what is in the sequencer at rendertime?

Can anyone explain what these modes do to help me get to the bottom of this?

I just switched the ‘play’ mode to ‘new editor window’ and then rendered again. This solved the problem. Now I am really confused!