Download

Second UV channel in scenes from 3dsmax does not work?

Hey,

I have a few different objects in my 3dsmax** scene **(single object works fine) and I exported all of them together because I wanted to keep the relations. Each of them is assigned a different material ID in 3dsmax, but that does not seem to make a difference.

Each of them as a second UV channel for lightmap, but it simply does not work in UE4. Normal texture works fine, even though they’re all on top of each other in the model viewer. Sadly, they’re also on top of each other in the other channel, even though it is using the right second channels for each object in the scene.

Is there a way to change this? It only works when I let UE4 create the lightmap, but I’d like it to just use mine.

Okay nevermind. I must uncheck that they are combined in one mesh while I import, and then just choose all of them together from the asset browser and they are placed in relation and all my UVs are kept. Thanks. I am great.