Download

SDK 0.4.3 out

Confirming : all is good
latency in 4.5.1 : Same (13.3ms)

BUT FOV feel reduced as they added some gradient to the view, not fun.
So on the UE4 side purely : not worth the upgrade : no gain.

Cheers

i will try now, if not firmware i can go back.

One word: disaster.

1.- I must activate Aereo again if not UE4 not work.
2.- I launch my demo and fps got stuck in 37.20
3.- I disable Vsync and got 76fps when i got 100-110fps in my demo.

Mirror on/off not change the fps.

i back to 0.4.2 :confused:

OK, sneaking in a fix for stereo rendering of the HUD could be what pushes me to upgrade to 0.4.3. Any chance you guys could also fix stereo rendering of DBuffer decals? :smiley:

  • Dave

New unreal user here, is there a tutorial around on how to update to the latest SDK?

Hey guys, so I dislike the new vignette, and wrote a blog post about how to disable it (haven’t tested yet, but I think it should work, the engine is compiling now). The post has the file and line necessary to disable the vignette and reclaim our precious FOV, and still reap the benefits of 0ms post-present latency and better chromatic aberration.

Just curious, why do you want to use the HUD in VR? It’s useful for quick testing yes, but we’ve gotten much better results by rendering on quads in the game world.

404 - Page not found??

Works for me - you need an active subscription to UE4 and to have your Github acct linked and logged in to see it.

Ok thanks, will try later!

I was using the HUD as a quick damage flash for my player for when the zombies smack them around. I also wanted to add some blood splatter to their view and thought the HUD might work for that. But now that I’ve tried it out (I merged the HUD fix into vanilla 4.5.1 as I’ve decided to still hold off on upgrading to 0.4.3) the HUD may draw itself too far in front of the camera for my purposes. I’ll likely have to go with an extremely close quad after all for a blood-in-yer-eyes effect.

As for my game in general, I’ve decided to make it HUD-less, so I haven’t had to worry about using camera facing quads just yet.

  • Dave

After updating to 0.4.3 Unreal Editor crashes upon start when Oculus Rift is plugged in and turned to Direct HMD mode. :confused:

Terrible performance drop going from 0.4.2 to 0.4.3!

Noticed this post at answerhub by spyro, so added my comments in there:
https://answers.unrealengine.com/questions/124299/451-capped-at-375-fps.html

So after a bit more testing i found out that in my case is not really a massive drop in performance, but a couple of smaller things that combined can make some levels unplayable in DIRECT MODE (with and without mirroring).

  • 1st i noticed by turning off vsync that in 0.4.3 i get between 5 and 10 LESS fps than in the same map/location using 0.4.2 (on average).

  • 2nd i noticed that in 0.4.2 i get capped at 75 fps as long as i amd slightly above that (76 fps for instance). However in 0.4.3 as soon as i go below 83 fps i get capped at 37.5, is this normal?

So it’s both 5 fps harder to reach the threshold for good 75 fps vsync and this threshold is now 8 fps higher; this makes about 13 fps difference comparing 0.4.2 to 0.4.3.

More info in the answerhub link above.

It would be cool if someone else was able to reproduce this behaviour and chimed in!

Do you see this happening in both Direct HMD and Extend modes? With and without mirroring in Direct?

Yes only in DIRECT MODE (edited post above), mirroring on and off doesn’t seem to affect performance in 0.4.3 (as long as AERO is enabled, otherwise 0 fps!).

See answerhub for more details.

Ok i’ve tried Art_Oculus’ suggestion of disabling Intel’s SpeedStep in the BIOS and it does help getting rid of the spikes when profiling… Unfortunately this doesn’t seem to translate in any perceived improvement when actually playing the demo, still seems locked at 75 fps in 0.4.2 and 37.5 fps in 0.4.3.

I’ve attached 8 profiles taken from the same demo/location with different combinations of runtime/aero/mirroring/speedstep/vsync to see if it can help narrowing down the real problem.

https://answers.unrealengine.com/questions/124299/451-capped-at-375-fps.html

they released 0.4.3.1

Unfortunatelly it’s just an update for Unity.

No new runtime or updates on Oculus GitHub, i think we’ll still have to wait a bit more for a UE fix…

oh! true :(((