Download

ScreenSpace Reflections in new project not consistent.

Hi.

I’ve just been researching this and can’t seem to find a solution.

I’m making a new project using the VR motioncontroller template as a starting point.

Everything is looking good apart from reflections. I used a material from another project I bought which opens in 4.21 and has beautiful SSR reflections. But when I copy this same material to MY project which is also in 4.21 the SSR settings have no effect.

I have editor quality on EPIC. Have looked in the defaultengine.ini and r.SSR.MaxRoughness=0 is there

My post process volume covers whole scene as well but when SSR is enabled it’s not working right. If i go in the material and set the roughness blend to WHITE, SSR kicks in but it’s super reflective and then cuts off if a move the value to anything other than white to try and blend it in to get more matt reflections.

Anyone know if this could be something in the VR template settings? A setting i’m missing or something in one of the config files?

I’m literally playing with the same texture in 2 scenes opened next to each other, both in 4.21 - one is working and the other isn’t and as far as i can tell all settings are identical apart from one is VR template.

Any tips would be good!

Are you using Forward Renderer for VR? Because Forward Renderer doesn’t allow Screen Space Techniques (SSR, SSAO)

Thanks for the reply. Just checked in render settings and forward shading isn’t ticked so guess it’s not that!

I just loaded another scene up from 4.20 to 4.21 that wasn’t based on vr template and transferred that same material over. It works fine so I think this is for sure something in the VR template settings… I just can’t figure out what!!

Quick update - Now i know it’s VR related Ive done some more searches and there’s a few threads on this topic. It might not be best to have SSR in VR but still I cant find out how to activate it in the VR template just to test it. Someone said the defaultscalability.ini overwrites settings in defaultengine.ini but removing that still doesn’t enable SSR in the VR template so still no luck!

Backup your config files and overwrite them with the configs from the project where it works. See what happens.

SSR will not work in VR because it uses screen space for the sampling of reflections data. So while you might be able to enable SSR reflections, they are not going to work the way that you want. Additionally, we have no plans to get SSR working with VR as there is no easy fix for getting SSR working in VR. However, there is something else you can try, have you heard of Planar Reflections? Planar Reflections will give you much better results than SSR ever could and they will even work in VR. You can read more about how to use Planar Reflections in UE4 using the following link.

https://docs.unrealengine.com/en-us/Engine/Rendering/LightingAndShadows/PlanarReflections