RunUAT.bat error (Failed to Load Parent Error)

So after lots of playing around my error log has changed, I changed the directory for my game modes in the defaultgame.ini to fix the ’ " ’ error, so that error is gone, now I am getting this error in my console: http://pastebin.com/20wszkUK .

Basically it’s saying it’s failed to load the parent of my game modes, which I have called “L_Base_Gamemode” I right clicked this blueprint and made my two game modes a child of this blueprint. I have been following this tutorial A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums to get a better understanding of how to work with blueprints, if anyone knows how I could go about fixing this error it would really help!

There is also another warning that pops up in the console: "LogUObjectGlobals:Warning: Failed to find object ‘Class None.’ "

I’m not sure what that means, I’m newer to Unreal, and I’m assuming it has something to do with the main warning. But if anyone knows what that is too I would really appreciate the help, I can not build and package my project currently and I’m assuming these warnings are the error and this would be great to fix before I get deeper into this tutorial!

Hello NaviLlicious,

I took a look at your log and it seems as though you’re packaging for Windows 32-bit. Do you get the same errors if you package for 64-bit? Have you tried to package this project previously? If so, was it successful at that time? Are you able to package fresh C++ projects?

I have tried packaging on both 32 and 64bit and got the same error, I have not tried packaging previously but fresh projects will build and pack just fine.

Anybody know? I still haven’t figured out what is causing these warning messages and preventing my project from being packaged.

I was out for the weekend, so I’m back looking at this now. It seems from looking up some of the errors you’re getting that the problem could be antivirus related. Could you try temporarily disabling your antivirus to see if it may be blocking the building tools? If that doesn’t fix it, take a look at our Software Conflicts page to see if anything may be causing these problems.

I have disabled my anti virus and windows firewall but that didn’t seem to fix the issue, also looking through the software conflicts page I didn’t see anything that could be affecting my program.

The only things I see listed in your log that may point to anything are these:

LogLinker:Warning: CreateExport: Failed to load Parent for Function /Game/BluePrintsLogic/GameMode/L_Deathmatch.L_Deathmatch_C:UserConstructionScript; removing parent information, but keeping function

LogLinker:Warning: CreateExport: Failed to load Parent for Function /Game/BluePrintsLogic/GameMode/L_TeamDeathmatch.L_TeamDeathmatch_C:UserConstructionScript; removing parent information, but keeping function

LogUObjectGlobals:Warning: Failed to find object ‘Class None.’

MainFrameActions: Packaging (Windows (32-bit)): CommandEnvironment.SetupBuildEnvironment: WARNING: SetFrameworkVars failed. Assuming no compilation capability.

For the first two, it seems like it may be missing a blueprint that it relies on, or maybe a C++ class.

The 3rd error is a common one, but I’ve never actually seen it be the issue and tends to disappear when other warnings do.

The 4th is something I’ve never seen before. From searching online, all I can find on this one is the antivirus suggestion I made before and a person who claimed they fixed it by reinstalling Visual Studio. I’ll continue looking into these errors and what to try next.

Hmm, well for the first two I made a blueprint called L_Base_Gamemode and right clicked it then made L_Deathmatch and L_Teamdeathmatch children of this blueprint, but have not messed with the deathmatch or tdm blueprints since. If it can’t find the parent BP I’m not sure how to fix that, I have even deleted and recreated the DM and TDM BP’s as children to the same game mode BP and no luck.

It’s good to see the third warning doesn’t affect anything, that shows the first two warnings are probably the reason I can’t build/package. As for the fourth warning I have completely disabled my antivirus and firewall to see if it will let me package but I still get the error, I can try reinstalling VS to see if that works later tonight!

Edit: After reinstalling Visual Studio I still encounter the same error unfortunately, this is a real head scratcher

As far as the parenting goes, can you try opening up the affected children and reparenting them? This can be done from the Class Settings tab via a drop down menu under “Class Options”.

Sorry for the very late response I have been having unrelated computer issues, now that I’m pretty sure my pc is back to 100% I will try reparenting the child classes soon

After reparenting the blueprints to the base gamemode I still get the same error

This is a shot in the dark and might not work, but it would be best to try all of the options. Can you try creating a new project and then migrating the content over to the new project using the in-editor content migration tools? This may fix up some reference problems if they’re present. It’s unfortunate that this is taking so long to fix.

After migrating every folder to a new project I still get the same error and warning messages

I just noticed something else in your logs about Steam Connectivity. Could you please open your project’s DefaultEngine.ini and remove any lines that are related to OnlineSubsystemSteam?

This is the error:

Program.Main: ERROR: Exception in UnrealBuildTool: Failed to find value when parsing C:\Users\iansc\OneDrive\Documents\Unreal Projects\Onyx\Config\DefaultEngine.ini, line 24: !!Steam Connection Test!!

I was testing to see if steam would work with the game but thought I commented it out, I still get the error and here is a new copy of the pastebin: http://pastebin.com/b73MURhS

Could you please post your DefaultEngine.ini for this project? The fact that it’s still giving that error is odd. Also, do you have OnlineSubSystem and/or OnlineSubSystemSteam enabled in your build.cs? If so, please try temporarily commenting that out to see if it may be part of the issue.

I actually got it to package and build the project now by commenting out everything to do with the steam connection and online subsystems, but now when I try to open the exe for the file it pops up and error saying “Failed to open descriptor file”, here is the copy of the output log

PT1: http://pastebin.com/XyveDubk

PT2: http://pastebin.com/LPS2GtEB

(Had to split the log because it was too large for pastebin)

It seems like it has something to do with these warnings:

MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.26-21.25.49:369][ 0]CookResults:Warning: Warning Unable to generate long package name for …/…/…/…/…/…/Users/iansc/OneDrive/Documents/Unreal Projects/Onyx/Content/Maps/Menus.umap because FilenameToLongPackageName failed to convert ‘…/…/…/…/…/…/Users/iansc/OneDrive/Documents/Unreal Projects/Onyx/Content/Maps/Menus.umap’. Attempt result was ‘…/…/…/…/…/…/Users/iansc/OneDrive/Documents/Unreal Projects/Onyx/Content/Maps/Menus’, but the path contains illegal characters ‘.’

These are most likely resulting in the maps themselves not being included. The odd thing is what this warning is saying. It mentions that there is an illegal character in the path. The illegal character it mentions is a period “.” but the only one I see in the path is from the .umap extension. Can you check the complete file path manually and ensure that there aren’t any other periods in any of the folder names? I’ll be asking someone about this in the meantime.

We haven’t heard from you in a while, NaviLlicious. Are you still experiencing these issues? If so, was my last comment of any help? I’ll be marking this issue as resolved in the meantime for tracking purposes. Please leave a comment whenever you’re available and the post will reopen.