Running a server: Failed to load module 'PxFoundationPROFILE_x64.dll'

After packaging my game, and building the dedicated server. I get this error when trying to launch the dedicated server:

[2016.12.10-23.24.46:035][  0]LogWindows:Error: Fatal error: [File:E:\Unreal Engine - Git\Engine\Source\Runtime\Engine\Private\PhysicsEngine\PhysXLibs.cpp] [Line: 102] 
[2016.12.10-23.24.46:035][  0]LogWindows:Error: Failed to load module '../../../Engine/Binaries/ThirdParty/PhysX/Win64/VS2015/PxFoundationPROFILE_x64.dll'.

Full log attached.

Server Log

Hey Taurian,

I’ve run through the process using a clean Third Person project and I’m not running into the same issue. Have a look at the section of the wiki I linked below and ensure that you’ve run through all of the necessary steps:

Also, I’d recommend giving it a shot in a clean project if you cannot get your project to work to see if you’re getting the same error.

Let me know if that works for you.

Have a great day

I started up a test project. Same exact problem. I also re-downloaded and rebuilt 4.14.

Attached is the log.

Try removing the space from the Other Git Projects folder. Sometimes special characters can cause strange issues with projects.

Might not make a difference, but it’s worth a try.

I’ll try one more time on my end and see if I can get the same error.

Let me know if that helps

No luck. I’ve removed the spaces and tried it again.

It packages, and compiles successfully but when I try to run the *Server.exe I get the same exact error above.

I’ve gone ahead and attached the updated logs

I have same problem. Server successfully compiled and cooked, but when i run .exe file it crushed

Error: Fatal error: [File:D:\UnrealEngine-release\Engine\Source\Runtime\Engine\Private\PhysicsEngine\PhysXLibs.cpp] [Line: 102] 
Error: Failed to load module '../../../Engine/Binaries/ThirdParty/PhysX/Win64/VS2015/PxFoundationCHECKED_x64.dll'.

I tried on another machine, same issue. Everything builds, but we get the PhysX error above.

Tried this with 4.14.2 – Same problem.

Do you have any Antivirus software that could potentially be removing that file? I’ve seen that sort of issue occur before with load errors such as this.

No. No antivirus. Nothing even close to that installed on any machines here.

Regarding the wiki link I provided above, are you deviating from those steps at all or making any sort of changes?

I’ve tried it on my end multiple times and it seems to be working without any issue so I’m wondering if there is something that we are doing differently.


I got the same errors when trying to run the server executable with a shipping build, after building a dev build it seems to solve that issue, but I got a different error instead. Not sure if this belongs here or is related to the same issue tho. (UE 4.14.2)

]LogWindows:Error: Assertion failed: !bCheckAdded || NodeRef.bAddedToGraph [File:H:\UnrealEngine-release\Engine\Source\Runtime\CoreUObject\Public\Serialization/AsyncLoading.h] [Line: 245]


I’m not sure if that’s the same issue either, honestly. For the sake of keeping error messages separate, would you mind creating a new topic in the Bug Reports section?

Please provide as much information as possible, including repro steps, log files, callstacks, etc.


MADHOUSE, I see that you have not created a new question.

But just in case I will write here, can someone come in handy.
Specifically, my problem was that check mark (Project Settings).

It needs to be turned off.

Thank you all there.

Tried this on the 4.17 build, got the same error.

This is a problem with the appropriate DLL’s not being packaged with the build (not sure what’s causing that to happen).

You can retrieve the DLL file from your (engine build)\Engine\Binaries\ThirdParty\PhysX\Win(architecture)\VS(version)\

Once you paste them in your (game build)\Engine\Binaries\ThirdParty\PhysX\Win(architecture)\VS(version)\ everything will be good to go.

If someone figures out what makes those files not be packaged, let me know.

I run into the same issue, and has sucessfully resolved it by updating VS2015 update2 to update3 and reinstalling vc_redist.x64.exe.