"Run on Client" replicated event is running on the server

When I call an event that is replicated to “Run on owning client”, that event gets called on the server and not on the client. I don’t know if this is a bug or some config that I changed, but I just can’t make it work again.

My Player BP:

Game (look at the upper left corner):

Please someone help me!
Thanks in advance!

“Run on owning client” will run in the server and then show it only in the owning client… So, that’s why is showing like that… You should test it with more players…

Tested it with 4 and it didn’t work. And even if it had worked it would be kinda weird that it didn’t with 2. But anyways, thanks for the reply!

Well, TBH, I don’t know exactly what are you trying to do, but in THIS CASE if you want that Print Test line to work on the clients, you should remove that Switch has authority. But you should give us more information on what are you trying to accomplish! (Y)

EDIT: Also, for debugging you should use a Key in the keyboard, not the Begin Play node, so you can control when to test your functions.

What is the object with this logic? Who is Owner of object { GetOwner() } ?

I solved the problem. I don’t know how I did it, I was just playing with it to see if got any luck and it worked. Thanks to everyone that helped me!

I met your case, too. I solved it by adding a Delay node.

Hi, where did you add the delay node?