Download

Reverb issues on mac: Cutting off tail end of impulse response

My system specs before we begin:

iMac (Retina 5K, 27-inch, Late 2014)
4 GHz Intel Core i7
32 GB 1600 MHz DDR3
Macintosh HD
AMD Radeon R9 M295X 4096 MB

Hey you guys, I’m still fairly new to Unreal, so please go easy on me. I’ve been sound designing. The sound part is going great, designing and inserting cues, I understand all of that. But when I create an audio volume (assign its bounding box dimensions) and assign a reverb to that audio volume, all of the sounds I assigned a sound class to for that reverb play for only a split second and then they cut off; in other words, it isn’t playing the entire impulse response. Yes, I’ve tried tweaking with the settings. I’ve made sure all of the reverb settings are long enough to even give me a steady impulse response. I’ve made sure there are no weird falloffs or fade ins. In fact, I tried making some default settings just to see it could play it like normal, and it gives me the same result. The reverb starts and then just cuts off all of my audio. I’m a pretty big sound nerd, so I know this kind of thing should be working simply, but it’s not. Sounds like a super weird glitch or something. I’ve tried restarting my computer and everything. My next option is to just re-install Unreal and see what happens. Any ideas?
Thanks!

Okay, I figured out what it was. I didn’t realize that Unreal only plays the reverb attached to the length of the audio. In other words, I had to re-edit my footsteps to be longer time and add silence to the end of the track. This, in essence, allows the reverb effect to play its full impulse without being cut short.

That seems like a bad idea. That’s really space inefficient