Replication in my weapon only working on server!

I know there are a lot of other threads out there on this question, but I can’t seem to find what I’ve done wrong even though I’ve looked through countless of threads and followed the youtube tutorial.

Here is a picture showing my blueprint:

I’ve got replication set on my gun and made sure what only should be called on the server does etc (Authority).

I’ve gone through my whole code and the problem seems to be the ServerProjectileLaunch. If someone can see what’s wrong it’d be great ^^.

The second part I did was because I was unsure if it had anything to do with the spawning of my projectile prefabs over network. Also tried to see if my health script worked at the same time so ignore that ^^. But the second code works as a charm, no matter if you’re playing as client or server.

Best Regards
Robert Carlsson

Found out what the problem was, seems replication from client to server only works if you’re owning the Blueprint it is run from. The weapon didn’t count as mine therefore it could only be run if the server had picked it up. Made a workaround by making an additional event inside the playercontroller that made the client-server call there. That way the server then told the weapon to shoot.

Here is a link if someone else encounters the same issue as me!

So, you call the custom event inside the character from the controller? Can you send image?

Sure, I’ll post a picture as soon as i get home. But the gist of it is like this:

Left Mouse Clicked (Inside character controller)-> Custom event(Replicate to server)->Custom event inside weapon that starts the weapon mechanics.

Hope that made sense, but will post pic when I get home for further clarification.

Can you add the pic? I am having the same problem :L

Sorry for the late answer, fell asleep and haven’t been home since then.

Here is a picture that hopefully explains some.