Download

renderVelocity and rigid animation performance drop

I’m a bit new to the animation end of UE4, but I’m working with VR, so performance is critical, and I’m running into some issues with importing and playing back rigid animations.

We have a particle system in maya, where we’ve baked the particles out to individual assets with their own keys. About 100 of them. We then brought those into UE4 using the import as skeletal option to get the rigid animation applied, set each to Animation Asset, and go.

It works, but in VR I saw a massive slowdown whenever the view includes the animated assets (from a clean 75fps to 30fps). So I ran profilegpu (which still has a broken transparent background which makes it very very difficult to read). That told me that something called “renderVelocity” was taking a lot of time.

Now I’m new to UE4 in this regard, but I assume this is the process that renders velocity channels for use with motion blur and any other postFX. But I don’t need any motion blur or postFX, since VR doesn’t want them anyway. Is there a way for me to keep the animation, but kill the velocity render to speed things up? Or do I have this all wrong?

Perhaps having 100 rigid animated models is just too much for good performance overall? Any thoughts? Thanks folks!

Andrew

Do you still have the rigid body nodes now that everything is baked animations?

It’s purely baked keys on geo. There’s no physics going on, if that’s what you’re asking.

What’s the readout in profiling? the ms and %

Edit: Hang on, did you disable dynamics?

Double Edit: I should clarify this question because you basically asked how to do this in UE, but I’m asking if you did it in Maya.