Download

Removing guns for a realistic environment in UE 4.10.2?

Hello all

I’m hoping someone can kindly take the time to help me. In earlier versions the below worked. In Unreal Engine 4.10.2 it doesn’t seem to work and I must be doing something wrong here. Basically I am looking to remove the guns from the screen so its just either hands or nothing for a more realistic feel when moving around the map. I have searched the net/vids and forum to try find a solution and can see no tutorials on this for the recent version. Below is what is advised for previous versions;

Open new project > Selecting First Person

Content > FirstpersonBP > Blueprint > FirstPersonCharacter;

Viewpoint > Component > Mesh2P (was Mesh1p in earlier version) > Details Panel > Search Owner

Comes up with two options;

  1. Owner no see (Need to tick to remove gun/hands)
  2. Only owner See (Ticked by default)

Compile > Save > Play

Thanks for your time and hoping there is a simple solution to this

Cheers Matt

Uncheck is visible from the gun?

You can just use an Archvis player controller.

If you have your own character up and running, try changi g the default pawn in the game settings so you dont have to mess around with anything else while testing your level

I’ve tried both ways and they don’t seem to change anything, so odd.

The Archvis Controller adds a free floating cam, notma person unfortunately bud thank you.

6ixpool, I’m running this from default, however I’m 4.10.2 the character default hands and gun are no longer a blue outline, UE has added a robotic arm and detailed gun. I have followed the guide, the only difference is the mesh2p from previous UE version. It’s frustrating as this seems such a simple thing. Thanks for responding though.

The older versions both the gun and arms were a single mesh, thats why. Just go into the player controller and delete the hand and arm components, and then remove thing shooting mechanics leaving only the movement nodes. It is still pretty straight forward.

I’ve started a fresh firstperson project and deleted the arm (Mesh2P) and gun (FP_Gun) components. I get an error advising that the Blueprint is not a SkeletalMesh Component, and another advising SceneComponent must have a connection and that it failed. When I try play I cant move.

Its a shame there’s not simply a first person blueprint without guns you can just open.

Will try work this out.

Just change your player controller to the arch vis controller!

Shirk mind explaining further, as where I find this?

Go to Edit>Project Settings>Projects> Maps & Modes, expand selected gamemode and change default pawn class to ArchVisCharacter.

as0e7J6.png

I have changed the mode to ArchVisCharacter and when I hit play for the test it still shows the gun?

Please can you advise what I am doing wrong here. See below screenshots. Again thanks for your time.

Archvischaracter.jpg
Archvischaracter2.jpg

Resolved. I deleted all the gun sections of the Blueprint and then deleted the Gun and Arm Mesh. Now I am left with a crosshair and able to walk, sprint and jump around.

Thanks for all your help. I have saved both Blueprints for future projects.

Hey, I’m very new to UE4 but am having the same issue as you. Can you please post pictures of what you did to successfully remove arms and gun while still being able to move around? Every time I delete the Mesh2P and FP_Gun my game locks me in place. What specifically did you delete in blueprints to fix this? Thanks!