Reimporting mesh from wrong Source File

Im not quite sure how to replicate this bug, but it happens from time to time when reimporting the static mesh where it will import from the wrong source file, causing you to have to go into the Import Settings and change the source file back to its original. I think this has to do with having a few similar named assets in the same folder when importing.

Hi Shirk,

I gave this a test for a few minutes, but didn’t notice anything out of the ordinary. Without something more specific to reproduce the issue more consistently any ticket entered for this wouldn’t really go anywhere. If you come across more accurate repro steps or notice something more specific I can test on my end to reproduce,

For reference, I tried with a couple of meshes named something like Box_00, Box_01, Box_02. I tried reimporting these a couple of times, shutting the editor down and restarting, reimporting again, changing the source location of the mesh, and various other simple tasks with reimporting, but I had no luck in noticing any issue.

If you have more details or something that can reproduce the issue consistently, even if it’s not a 100% of the time thing, but more consistent than just occasionally please let me know.

Thank you!


I had a mesh with LOD0 LOD1 and LOD2 and when I pressed reimport to reload the meshname_LOD2.fbx file it actually changed the LOD0 file for a mesh I reimported last time I used that feature couple minutes before. Now I struggle with changing that LOD0 mesh, since LOD1 and LOD2 can be reimported through the asset editor but it seems the LOD0 can’t be.