Raytracing does not work with baked lighting?

Hey there,

i’ve run into a problem with the ray traced global illumination and I don’t know how to fix it.
I hope some of you guys can help me out. :smile:

When I bake the lighting, everything is perfectly lit up.
After the bake when I activate Lumen global illumination, it removes the baked lighting data and it replace it with the realtime Lumen global illumination. So far so good.

Now to my problem… When I activate ray traced global illumination instead of Lumen, it does not remove the baked lighting data. It just adds it up to it so that my scene is global illuminated by the baked data and the ray traced global illumination. (it’s just to bright)

How can I use the ray traced global illumination ONLY without the baked lighting?

Side info:

  • I use the path tracer to compare the lighting.
  • It’s an indoor scene.
  • I already tried changing the mobility of the light source.

My goal is to switch between baked lighting and ray traced global illumination without having a light difference. (I also want to use ray traced global illumination if I have it active)

Here are some pictures.
Baked


Lumen

Path Traced

Ray Traced

I hope you all could follow.
If there are some questions just go ahead! :grin:

You can tick ForceNoPrecomputedLighting in the World Settings and build the light again to clear the lightmap

You can tick ForceNoPrecomputedLighting in the World Settings and build the light again to clear the lightmap

Sadly that didn’t fixed it.
It just removes the lightmap.
When I use ray tracing without lightmap everything works perfectly fine but when I change to “no global illumination” then there is NO global illumination at all.

I would like to use my baked lightmap, when there is NO global illumination like Lumen or Raytracing.
And I would like to use NO baked lightmap, when I use Lumen or ray traced global illumination