Raytraced translucency still broken after a year

View images, Raytraced translucency makes transparent surfaces buggy and opaque, Images show a test scene, 1 with raytraced, 1 with raster. The one covered in artifacts is the raytraced one.

What blend mode and shading model is the RT test scene using? I’m working on understanding those aspects of a translucent material (not just Translucent blend mode) to do testing for ray tracing and raster. I’ve seen a number of different material graphs that use different blend modes and shading models, and ones that use either metallic 0 or 1, and use either white or black base color. What makes it impossible to use any of the options with ray tracing to get accurate translucency?

Blend mode is obviously transparent, the landscape is the default material, Shading model lit (Forward shaded translucency, Deferred rendering), Solid color as, well, color, simple panned normal maps as ripples/waves, Metallic set to 1 smoothness 0, Transparency shown in attachment.

So, looks to ne like you just aren’t doing things you are supposed to in your material.

It looks to ne like the artifacts are caused by sort priority of the mesh.

You are displacing the mesh for the waves, but the rendering engine doesn’t just know who is in front of who. You have to tell the material how to render that priority.

This is true even for forward shading btw, it just may not be as noticeable at the angle you are looking or something similar.

Assuming I’m right, you can find a pre-made solution within the community ocean project.

Also, if your material is set to forward shaded translucency. Ray trace on or off should have no impact?

Wrong. World position offset is not set up, nor is tessellation. I already specified only normals were used.

You shared a wpo based set of nodes.

Regardless, IF you are displacing the water, chances are the artifact IS a transparency sort issue.

Which brings another point. Could it be that the material sorting isn’t working on ray trace?

Recapture your skylight

I’ve noticed that even while using raytracing, it still seems to sample from the skylight for reflection/refraction.

If this is a skylight that moves at runtime you can recapture using blueprint, I use a timer because it’s extremely heavy to capture every frame. In 4.26p1 moveable skylights have a checkbox to update in realtime, but if you are using a stationary skylight you’ll have to recapture via blueprint… Stationary skylights don’t work correctly with GPU lightmass either… Not a good time to be a stationary skylight user :frowning:

Screenshots (only difference between these two images is that I recaptured the skylight):

By the way, 80% of your material graph could just be replaced by the “World Position Behind Translucency” node

Well, said wpo set of nodes is actually plugged into translucency and seemingly only has ever been used as such in tutorials. Note im dividing not multiplying

My guess is that the alpha sorting you are doing with the opacity isn’t understood by ray tracing.
generally speaking, ray tracing and alpha sorting are problematic at the engine level, so you aren’t wrong in saying its broken.

Does the node mentioned above bring any difference?
what about using single layer water?