Download

Raytraced Reflections Without Temporal Anti Aliasing

When I disable Temporal Anti Aliasing (TAA) Raytraced Reflections fall apart and become very noisy and jittery which also trips out things like Bloom and Depth Of Field making them look even worse. Luckily I don’t need this for real-time purposes because the only fallback I know would be TAA however when using the Movie Render Queue I still have trouble getting a noiseless or close to noise free image, I’ve tried using high reflection sample counts (64spp) which seemed to actually accentuate the noise because increasing the samples per pixel would result in the reflections becoming more visible.

When using the Anti Aliasing options within the Movie Render Queue increasing the Spatial and Temporal sample counts high enough would have a noticeable effect on the noise but was still far from being usable and is at the cost of unreasonable render times. I’d try very high settings like 32 spatial samples and 32 temporal samples totalling 1024 subsamples per frame which resulted in a much better image but still noticeable noise.

In Epics documentation for the Movie Render Queue they recommend disabling things like the Raytracing Reflections Denoiser/Temporal Accumulation (which is part of the denoiser) when not using TAA but in my experience this was very much needed to damper some of the noise and leaving it on gave a much better result. It’s important to note that I’m using a Max Roughness value of 1.0 (default is 0.6) which means that all forms of reflections will be raytraced, if I go back to the default value the noise is less of course because it falls back to SSR. Hopefully a fix or workaround can come along because in not all scenarios can TAA be used especially when it causes ghosting.

EDIT: It seems to be that the culprit for all the noise was coming from my sky dome sphere in my scene which I had disabled shadows for but still had “Visible in Ray Tracing” enabled and was messing with the reflections causing it to amplify the noise and have a sort of fireflies effect, disabling it so far still results in noise but increasing the samples per pixel actually has an affect on the noise now, also rendering using the Anti Aliasing options within the Movie Render Queue actually works significantly to clean the noise. If anyone is experiencing a similar issue perhaps this may be a fix though it will be at the cost of changing the lighting of your scene which you may liked the way it looked before though technically wrong.