Random Sequence Player gets stuck if Blend In set to 0


I’m trying to use the Random Sequence Player node in a state machine. I’m basically just wanting to randomise between a bunch of running anims that have some variations but have matching start and end frames. With default Blend In 0.2 I get a noticeable glitch where the legs skip as the next animation blends in. To avoid this I’m trying to set the blend to zero between between each running loop, which seems to work as expected. However, after the last loop (I think it’s the last one) in the sequence the character gets stuck in a static pose with a couple of bones flickering.


Ok I’ve managed to fix it by setting Blend In to 0.02